Does Spybot – Search & Destroy Support Windows 8?

There should be no problems with the compatibility under Windows 8 (also 64 bit):

Here you are!


For all those using Windows 8.1, please use Spybot 2.2 or later. Spybot 2.2 solves any incompatibility issues and allows to run Spybot on Windows 8.1 systems.

 

 

 

This page shows content from our old website. It might move in the near future. To get the most up to date information, please use the navigation menu at the top.